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12d Model 
Civil and Surveying Software 

 

 

 

 

SUMMARY 
Trimble Geomatic Office (TGO) and Trimble Survey Controller Software are no longer 
supported by Trimble. 
 
Trimble Business Center (TBC) and Trimble Access are now Trimble’s new and only 
supported software. EXDS doesn’t have a Trimble Access Emulator as Trimble 
require you to be a current user and to register your equipment to use Trimble 
Access. 
 
Trimble Business Center (TBC) can be downloaded off the Trimble website 
http://www.trimble.com/construction/heavy-civil/software-solutions/Business_Center-
HCE_download.aspx 
Note this is the Heavy Construction version (HCE), which is free, and a lite version 
that does most basic functions. 
 
If you’re a Trimble client and are doing a lot of Network Adjustments and Static GPS 
reduction you should then consider purchasing Trimble Business Center (TBC). 

  
Codelists 
 

- Codelists can be created a number of ways for the Trimble. Codelists created 
in Trimble Business Centre (TBC) and Trimble Access on the instrument are 
now the same file. This file is known as Feature Definition File (.fxl). 

                     
- Codelists created in Trimble Geomatic Office software (TGO) (this software is 

no longer supported) are called Feature and Attribute Library Files (.fcl). 
 

- Codelists created on the instrument in Survey Controller Software are called 
Feature and Attribute Library Files but with a (.fal) extension. These files are 
more basic as you cannot add attributes when creating a codelist on the 
instrument using Survey Controller Software.  

 
- Codelist makes it easy to code, free coding (multiple coding) and to code 

attributes (tree size, species etc). 
 

- EXDS has sample codelist and map files – which use tree size attribute to 
scale the symbol. 

 

Format Files 
 

- Trimble DOES NOT require Format Files like the Leica instruments. 
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Download 
 

- Downloading from your Trimble Instrument can be achieved a number of 
ways. 

 
- There are three routes to converting the data from the card into useful info: 

 
o Using Trimble Link (direct downloading), which is downloaded for free 

from the Trimble Website. This software is like Windows 7 Mobile 
(Active Sync) and your Survey Controller with your data needs to be 
connected to your PC or Laptop so the data can be downloaded 
directly to 12d. 

 
o Setting your data recorder to Trimble Feature String in 12d and the 

using the convert raw function to convert your Trimble Link Job File 
(.tlk) to a Field File (.fld). 

 
o The last way is to use the export function on your Trimble to export to a 

format which can be used by 12d, which then the file can be copied 
over by USB or by using Windows 7 Mobile (Active Sync). These file 
formats can include the following file types: .csv, .dat, .txt, .sdr etc…. 

 

Upload 
 

- Upload by copying files directly onto your instrument by using Trimble Link or 
by using a USB to copy the files. Also Windows 7 Mobile (Active Sync) can be 
used to transfer files directly. 

 
- Points upload by creating a csv file File I/O => Data Output => xyz => xyz 

general and copied to the instrument using the above options. Points can also 
be upload using Trimble Link using the 12d option called Survey => Trimble 
=> Create Points Upload File.  In 12d v9 it can be found under Survey => 
Upload => Create Points Upload File (new). 

 
- Strings can be copied by creating a dxf file and copying it to your Trimble Data 

folder. 
 

- Triangles (T.I.N.) Upload by Survey => Trimble => Write TTM File.   In 12d 
v9 it can be found under Survey => Upload => Create Triangle Upload File. 

 
- Trimble Roading Files using Cross-Sections are uploaded by using Survey => 

Trimble => Trimble Link Roads. If you are using Strings then using the 
option File I/O => File Output => Genio is used. This option is best for 
complex roads. . In 12d v9 it can be found under Survey => Upload => Create 
Road Upload File (new). 
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CODELISTS 
 

EXDS has codelists (and associated map files) for use on all Trimble 

Instruments (J:\SURVEY\Trimble\Codelists). 

 

 

The codelist for all Trimble Instruments are the same, if created in Trimble 

Geomatic Office the .fcl file can be converted in Trimble Business Centre to 

create a .fxl file to use with Trimble Access.  

 

 

They can be created in Trimble Geomatic Office (TGO) under the CAD tab then 

go to Feature and Attribute Editor and the codelist file is given the extension 

.fcl. Then the codelist is exported from TGO using File => Export and copied 

to the Trimble Data folder on your instrument. 

 

 

 
 

 

 

 

 

They can be also created on the instrument under the Configuration icon then 

Features and Attributes Libraries but you cannot add attributes like Tree spread, 

diameter and species etc. This codelist is given the extension .fal. 
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If your using the more modern Trimble Business Centre (TBC) then you create 

your codelist under Tools => Feature Definition Manager. This will create a 

codelist file with an .fxl extension. Then under File => Export you can export 

your codelist to a specified folder usually your Trimble Data folder on your 

instrument. 
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All codelist are copied to the Trimble Data folder on your instrument. 

 

 

 

 
 

 



 
 

 
Trimble Cheat Sheet 

12d Model                                                                         May 2012                                                                                
Page 
Civil and Surveying Software 
Distributed by Extra Dimension Solutions 

4 

Extra Dimension Solutions 

 
 

 

Now your codelist is ready to be used on your Trimble Instrument, no other 

steps required. 
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REDUCING TO 12D 
 

Trimble Link 

 
There are a number of ways to reduce your data from Trimble instruments to 

12d. The best way and most direct way is to use Trimble Link, which will reduce 

your data directly to 12d and create a field file (.fld).  

 

 

Trimble link must be installed prior to attempting to upload or download data to 

the Trimble controller. The user will need to have access to the Internet and have 

administrator rights. 

 

 

Trimble Link can be found on your 12d installation DVD under the other 

software tab or contact your local Trimble distributor. To install just run the .exe 

file and follow the prompts. 

 

 

When running Trimble Link for the first time with 12d you will need register the 

software with Trimble. Please ensure you are connected to the Internet when 

doing this.  
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An authorisation code is required. To register click on the link to the Trimble 

web page as shown below. 
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The registration page appears. Scroll down to the bottom of the page and fill in 

your details. Select Send Registration Now. 

  

 

 
 

A registration number will be sent straight away. Record this number for entry 

into the Registration panel. 

Exit the panel and return to the Registration panel. 

Type in the Registration number, Select Yes, I Agree to accept the licence then 

select OK 

Select Close to exit the Tips panel 

 

Trimble Link is now registered. Proceed to download your data. 
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Trimble Data Transfer Utility Software 
 
Trimble Data Transfer Utility Software is free software provided by Trimble for 

Data Transfer between Instruments and Controllers to their CAD software on the 

users PC. 

 

As the data transfer software is provided by Trimble any updates need to be 

downloaded from the Trimble web page link below. 

 

http://www.trimble.com/datatransfer.shtml 

 

Or by selecting Trimble Data Transfer Utility in the Survey Data Download 

panel. 

 

 
 

Installation instructions are included on the web page. 

 

It is very important that Trimble Link, Trimble Data Transfer Utility and 

Trimble Access Installation Manager are updated regularly.  
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Downloading To 12d using Trimble Link 
 
Once your Trimble controller is connected to your PC using a USB cable or the 

Trimble Survey Controller docking station, you can then to proceed to download 

your survey data into 12d following these steps below. 

 

Survey => Setup 

 

 
 

Then select the Data collector called Trimble Link Feature String as shown 

below and then press Set and then Finish. 
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Now go to Survey => Download Raw 

 

 
 
 

Then select Download. 
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WARNING: You only want the Download as reduced cords boxed ticked if your 
survey is a GPS pickup using code with NO ATTRIBUTES.  
 
This also reduced the GPS reading as Vectors so you can edit instrument if a mistake 
is made in the field. 
 
As having this box ticked stops attributes from reducing. 
 
 If you are downloading a GPS survey with attributes make sure on the Trimble Link 
Feature String Data collector under the Instrument tab that Sokkia 08KI as GPS points is 
ticked on and then select set then write as shown below. 
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Now once you select the Download icon. You should get a panel pop up with some 

information as shown below. Just untick the box on the lower left corner if you 

don’t want to see the message again, and then select Close. 

 

 
 

 

Now select your Trimble Controller from the list on your Devices as shown below. 

If your using Trimble access you with have a General Survey device possibly 

called Trimble Access. 
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Then select open and it should connect to your chosen device and display all the 

files held on that device as shown below.  

 

 
 

 

The raw file can be edited here prior to creating the field file as shown below. 
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To finish the editing and convert to a field file select OK. 

Once OK is pressed a Field File is created in your 12d job directory. 

 

Now you can import the Field File as you normally do by using 

 

Survey => Create => Field File 
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Then file in the panels as shown below, filling in the Function name, Default model 

and Report file by manually typing in what you want to call it (Usually your job 

number or name with a date). 

 

Then on the Field File tab where the cursor is, should be automatically populated 

by your newly created Field File. If not right click in the cell and browse for your 

Field File. 

 

 
 

 

You can also go to the Map File tab and use a Mapfile to apply the correct colours, 

linestyles and symbols to your survey.  

 

The others tab can be also used to tick on a box called “Show Check 

Measurements”. 
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The second way to reduce data from the Trimble is by using the Survey => 

Convert Raw option, which converts your raw Trimble Link Files (.tlk) to a field 

file. 

 

To use this option you must first select the Trimble Link Feature String from your 

Data Collector list. 

 

Survey => Setup 
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Then select the Data collector called Trimble Link Feature String as shown 

below and then press Set and then Finish. 
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Now once the data collector is set we can convert the Trimble Link File (.tlk) to a 

Field File (.fld) by following the steps shown below. 

 

Survey => Convert Raw 
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Now you need to select your Trimble Link File (.tlk). 

 

 
 

Use the folder icon on the right of the panel to browse for the location of your (.tlk) 

file. Once the .tlk file is selected the Field file panel is automatically created with 

the Trimble Link (.tlk) file name as shown above. 

 

Now press Convert and Finish.  

 

You can now reduce the data as you normally do using the field file. 

 

Survey => Create field file 
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Downloading SDR Files to 12d 
 
Firstly on your Trimble Controller you need export your data to a .sdr file. This is 

done by clicking on the Files icon as shown below. 

 

 
 

Then select Import / Export… 
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Then select Export fixed format files 

 
 

 

Now use the pull down arrow to select SDR33 DC as the file format.  

Also under File name click on the square box with three dots to browse to the 

correct directory where you wish to store the file.  
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Then press Enter. 

 

 

Now you are ready to import your newly created SDR File (.sdr) into 12d. 

 

 

 

 

 

 

 

 

Firstly you need to set the correct Data Collector to import the SDR File (.sdr) into 

12d. 

 

Survey => Setup 
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Then select the Data collector called Sokkia Feature String as shown below and 

then press Set and then Finish. 
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WARNING: You need to tick the box under the Advanced Tab called 
 “Allow bad line lengths” so your SDR File can reduce into 12d without any errors.  
 
This option is found by selecting the [edit] icon on the lower left of the Data Collector 
Panel. 
 
 

 
 
 
 
 

Now once the data collector is set we can convert the SDR File (.sdr) to a Field File 

(.fld) by following the steps shown below. 
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Survey => Convert Raw 

 

 
 

 

 

Now you need to select your SDR File (.sdr). 
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Use the folder icon on the right of the panel to browse for the location of your (.tlk) 

file. Once the .tlk file is selected the Field file panel is automatically created with 

the Trimble Link (.tlk) file name as shown above. 

 

Now press Convert and Finish.  

 

You can now reduce the data as you normally do using the field file. 

 

Survey => Create field file 

 

 

Downloading CSV files to 12d 

 
Firstly on your Trimble Controller you need export your data to a .csv file. This is 

done by clicking on the Files icon as shown below. 

 

 
 

Then select Import / Export… 

 



 
 

 
Trimble Cheat Sheet 

12d Model                                                                         May 2012                                                                                
Page 
Civil and Surveying Software 
Distributed by Extra Dimension Solutions 

4 

Extra Dimension Solutions 

 

 
 

 

Now use the pull down arrow to select Comma Delimited (*.CSV, *.TXT) as the 

file format.  

Also under File name click on the square box with three dots to browse to the 

correct directory where you wish to store the file.  

 

Also select what data you would like in each field (column) of the file as shown 

below. 
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Then press Accept. 

 

 

Now you are ready to import your newly created SDR File (.sdr) into 12d. 

 

 

 

To import a CSV file into 12d we use the following procedure.  

 

File I/O => Data Input => xyz => xyz general 
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Now you should have a Read X Y Z General Files panel open as shown below. 

Now under the Files tab select your newly created CSV File by selecting the folder 

icon and browsing to the correct location. 
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Now fill out the Basic tab as shown below. You must select a Default linestyle by 

select the Text Symbol (A). You also need to type in a default model for data to be 

added to a selected view. 
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Now fill out the Format tab as shown below. You must change the Delimiter to a 

comma “,” as shown below. This is the Delimiter in the CSV File that separates the 

values. 

 

Now in the Column number in file information table you need to select the correct 

value types to the correct columns as shown below. 

 

This MUST be the same as when you exported from the Trimble controller. 
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Then select the Mapfile tab if a Mapfile is to be used to give your survey the 

correct linestyles, colours and symbols. 

 

If you will use this same format all the time, you can write a file name in the 

Parameter file panel and select write (pencil icon). 

 

Then once you finished select Read. 
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UPLOADING FROM 12D 
 

Points from a CSV File 

 

Uploading points to Trimble instruments and controllers can be done by creating 

and uploading a CSV File. These files are created in 12d using  

File I/O => Data Output => xyz => xyz general 

 

 
 

Then select the data source you want to export. Change the Delimiter to a comma 

and nominate the values you want displayed in each column of the csv file. Then 

press write.  
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Now copy the newly created csv file from your 12d project job folder onto your 

USB stick or transferred by Windows 7 Mobile (Active Sync) and stored in the 

Trimble Data folder.  
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Once the file is in your Trimble Data folder on your controller you need to import 

it into your current job as shown below. 

 

 
 

Then select Import / Export… 

 

 
 

 

 

Then select Import fixed format files 
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Now use the pull down arrow to select Comma Delimited (*.CSV, *.TXT) as the 

file format.  

Also under File name click on the square box with three dots to browse to the 

correct directory where you wish to store the file.  

 

Also select what data you would like in each field (column) of the file as shown 

below. 

 

 

 

 
 

 

Then press Accept. 

 

 

The points are now uploaded to your job on the Trimble controller and can be now 

set out using Survey => Stakeout => Points. 
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Points from Trimble Link upload 

 

This method uses Trimble Link to automatically upload your set out points to your 

Trimble controller. Connect the controller to the computer by an approved method 

(USB Cable or Trimble docking unit) then select the follow option in 12d. 

 

Survey => Trimble => Trimble Link Points 

 

Survey => Upload => Create points upload file (new) – 12dv9 
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Tick the check box “Upload directly to Trimble device” to upload your points 

directly to the Trimble controller. 

 

 

Select the data to upload using one of the source box options. 

 

 

Tick the check box to only upload numeric point numbers if you have no letters in 

the point numbers. This allows you to edit the number range. 

 

 

Select Write 
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Select the correct controller to upload your setout points too. If you’re using 

Survey Controller 12.46 select it. If you’re using Trimble Access your device could 

be called a General Survey or General Survey Data Card. 

 

 

 
 

Now give the setout points an appropriate file name usually a job name or number 

and then select Save. 
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The file can now be opened and viewed in the controller. 

 

 

 
 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 
 

 
Trimble Cheat Sheet 

12d Model                                                                         May 2012                                                                                
Page 
Civil and Surveying Software 
Distributed by Extra Dimension Solutions 

4 

Extra Dimension Solutions 

 

 

Strings from a DXF File 

 

A dxf file can be used for setout of strings and also as a background file to display 

your data on the Trimble controller. 

 

If you’re using a dxf to setout you should export a 3d dxf from 12d. If you only 

want your dxf to be a background picture then a 2d dxf should be fine. 

 

 

Select option File I/O=>Data Output=>DWG/DXF/DXB 
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As above select the data to list, select dxf as the format, then type in a file name. 

Select 3d as the dimension and then press Write. 
 

 

Copy the dxf file to the controller using Windows 7 Mobile (Active Sync) or a 

USB Stick and place it in the Trimble Data Folder on your controller. 

 

 

 

 

On the controller open the job to setout or create a new job if you need too. 
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Select Files => Open Job then pick the required job 
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Now select File => Properties of current job 

 

 

 
 

 

 

Select Active map then select dxf file. The layers can be then toggled on or off. 
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Now tap the screen twice on the word 3DSETOUT so you get a dotted box with a 

tick as shown below.  

This means the dxf is not only visible on the controller but the double tap means 

you can now select the strings to setout. 

 

 

 
 

 

The strings can then be seen in the display and used for 2d / 3d setout. 
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TIN upload for setout 

 

 

Triangulation Irregular Network (TIN)  

 

 

Select option Survey => Trimble => Trimble Link Triangles 

 

Survey => Upload => Create triangle upload file – 12dv9 
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Select File Type Trimble binary *.ttm (This is a Trimble Triangle File) 

 

Tick the check box to Use Trimble Link 

 

Tick check box to Upload directly to Trimble device  

 

Type in a TIN name to create on the controller 

 

Type in the TTM output file name 

 

Select the TIN you want to setout by selecting the tin icon and choose from a list 

 

Select the polygon around the edge of the TIN. This is usually the TIN boundary. 

This is also optional 

 

Select Write 

 

 
 

Select Yes to confirm the number of triangles. 
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Select the controller then select Open 

 

 
 

 

Type in the file name and select appropriate file format version if applicable 

 

 

 
 

Select Save 
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The TIN can now be used for height when setting out using the Trimble controller. 

 

Once you start a new job or open an existing job under the Files icon. 

 

You can now setout to your TIN by using the following option 

 

Survey => Stakeout => DTMs 

 

 
 

 

 
 

 

As shown below you have to select your TIN from the DTM pull down list. 

 

You also have the option to apply a vertical offset to your TIN. (This can be handy 

when setting out Subgrade levels for a Road). 

 

Also do forget to have the correct Target height entered as this will effect your cut 

& fill values. 
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There is also an option when staking out to a line on the Trimble controller to set 

the levels out to a TIN as shown below. 

 

This is found by select the option tab and toggling down to page 3. This is found 

under Survey => Stakeout => Lines 
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Road Sections and Strings for Setout (Simple Road) 

 

Create upload file for road alignment and associated sections 

 

Using Survey => Trimble => Trimble Link Roads 

 

Survey => Upload => Create road upload file (new) – 12dv9 
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Select your Alignment String (Usually your Super Alignment G-String). This will 

then automatically populate the Job Name below. You can change the Job Name to 

something more appropriate such as ROAD 1. 

 

Tick on Upload directly to Trimble device as this will automatically create a 

Trimble Link Job on your device. If untick a .dc file (data collector file) is created 

in your 12d project folder and you’ll have to transfer it manually to your device. 

 

Then Tick on Report vertical alignment and Report X-sections so you can use the 

alignment to setout to a level. 

 

Select your 12d model that the road cross-sections are in. Also you can choose a 

start and end chainage if you only want parts of the alignment. 

 

Once happy select Write. 
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Select OK to accept the warning 

 

 
 

  

Select the controller then select Open 
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Type in the Road name to create then select Save 

 

 

Now on your Trimble Controller go to Files => Open Job and select your road job 

or create a new job. 
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Then select Survey => Stakeout => Roads 

 

 
 

Then select the name of the road you want to setout. 
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Select the chainage and offset you want to setout and you should have a displayed a 

bearing and distance to that point as shown below. 

 

 
 

You can also select the XS icon to view the setout in Cross Section view. 
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Road Strings for Setout (Complex Road) 

 

The genio format is used to create an upload file with alignment strings and design 

strings. This is done in two parts. 

 

Create genio file of alignment first. 

 

File I/O => Data Output => Genio 
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Select alignment string (Super Alignment –G String). 

 

Type in file name eg ROAD 1 this will then automatically give the file a .mos 

extension. 

 

Change alignment/arc dimension to 6d 

 

Tick check box for 77 format. 

 

Select Write 

 

DON’T FINISH PANEL YET! 

 
You now need to write out the rest of the road strings using the SAME panel and 

file name. 
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Select model for road strings. 

 

Keep previous file name. 

 

Change alignment/arc dimension to 3d 

 

Select Write 

 

 
 

Select Append to append to the existing file 

 

 

Copy the genio file to the controller using Windows Mobile 7 (Active Sync) and 

Windows Explorer.  

Place it in your Trimble Data folder on your Survey Controller. 
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Then select Survey => Stakeout => Roads as previously shown when setting out a 

simple road. This time select the Genio File with the .mos extension. 
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Rail Strings for Setout 

 

This option is used to export your alignment and strings in a rail job. This is only 

used if the transition curve type is a Cubic Parabola. 

If you try and use the above methods your alignment will fail, as the Trimble 

Instruments could not read the Cubic Parabola into its software. 

 

First before starting you need the correct Transition Mapping file to use in 12d. 

Please contact EXDS on (02) 9453 9449 and we can email you the correct Trimble 

Transition Mapping file. This can be placed in your 12d user_lib folder. 

 

Select Survey => Leica => 1200 => Roads (Yes, this is correct) 
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Then type in a job name and press enter so the File name will be automatically 

created with an .xml extension. 

 

Select the Trimble_Rail.trans_map to map the Cubic Parabola into an xml language 

that the Trimble Software recognises. Remember where you place this and you the 

browse icon to find this folder. 

 

Leave the Create database unticked as we are using a Trimble Instrument so the 

Leica DBX Files are useless to us. 

 

Tick on put all stringlines in a layer. 

 

Select the Alignment string i.e. the G-String 

 

Tick on Include Alignment in layer if you like. 
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Then select the model of your rail strings in the Stringlines model panel. 

 

Then select Write 

 

This is still a work in progress, as Trimble hasn’t managed a way to get the 

alignment into their controller from TBC or 12d with the Cubic Parabola 

transition curve. 

 

You can import this XML file into Trimble Business Centre (TBC) and export 

it to a more user-friendly format but it will still chord the alignment. 

 

The only way to get an alignment string into a Trimble controller is by 

manually entering the alignment into the controller. 

 

I will update at a later date. 

 

 

 

 

 

 

 

 

 


